Posted on

MongoDB libbson 1.7.0 bson-iter.c bson_utf8_validate length memory corruption

A vulnerability has been found in MongoDB libbson 1.7.0 (Database Software) and classified as critical. Affected by this vulnerability is the function bson_utf8_validate of the file bson-iter.c. Upgrading eliminates this vulnerability. A possible mitigation has been published 3 weeks after the disclosure of the vulnerability.