Posted on

OpenCV up to 3.4.6/4.1.0 cascadedetect.hpp HaarEvaluator denial of service

A vulnerability, which was classified as problematic, has been found in OpenCV up to 3.4.6/4.1.0 (Image Processing Software). Affected by this issue is the function cv::predictOrdered of the file modules/objdetect/src/cascadedetect.hpp. Upgrading to version 3.4.7 or 4.1.1 eliminates this vulnerability.