Posted on

UnrealIRCd up to 3.2.10.6/4.0.5 Certificate Fingerprint modules/m_sasl.c m_authenticate AUTHENTICATE spoofing

A vulnerability, which was classified as critical, has been found in UnrealIRCd up to 3.2.10.6/4.0.5. Affected by this issue is the function m_authenticate of the file modules/m_sasl.c of the component Certificate Fingerprint Handler. Upgrading to version 3.2.10.7 or 4.0.6 eliminates this vulnerability.