Posted on

Linux Kernel up to 5.2.17 Beacon Head net/wireless/nl80211.c validate_beacon_head memory corruption

A vulnerability was found in Linux Kernel up to 5.2.17 (Operating System). It has been classified as critical. This affects the function validate_beacon_head of the file net/wireless/nl80211.c of the component Beacon Head Handler. Applying a patch is able to eliminate this problem. The bugfix is ready for download at marc.info. A possible mitigation has been published before and not just after the disclosure of the vulnerability.